The UK Home Automation Archive

Archive Home
Group Home
Search Archive


Advanced Search

[Message Prev][Message Next][Thread Prev][Thread Next][Message Index][Thread Index]

RE: Installing axc - need help


  • Subject: RE: Installing axc - need help
  • From: "Paul Gale" <groups@xxxxxxxxxxxxxxxx>
  • Date: Thu, 23 Mar 2006 17:01:55 -0000

------_=_NextPart_001_01C64E9B.7BB78EEF
Content-Type: text/plain;
charset="Windows-1252"
Content-Transfer-Encoding: quoted-printable

I also tried adding it as a bootup action in Webmin and then tried to
manua=
lly start it but got the error:

=20

=20

Executing /etc/rc.d/init.d/axc start ..=20

Can't locate Config/IniFiles.pm in @INC (@INC contains: ./lib ./lib/site
/u=
sr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib/pe=
rl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/=
i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-mu=
lti /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/s=
ite_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-=
linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl/=
5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/li=
b/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_=
perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl=
5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.=
3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-threa=
d-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/p=
erl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5=
.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr=
/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl=
5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at /usr/share/axc/axc.pl
=
line 37.

BEGIN failed--compilation aborted at /usr/share/axc/axc.pl line 37.

=20

I setup the action simply as:

=20

/usr/share/axc/axc.pl

=20

Is that wrong?

Paul.=20

=20

________________________________

From: xap_automation@xxxxxxx [mailto:xap_automation@xxxxxxx=
] On Behalf Of Paul Gale
Sent: 23 March 2006 16:49
To: xap_automation@xxxxxxx
Subject: [xap_automation] Installing axc - need help

=20

I installed Greg=92s Asterisk plugin a while ago but never got it to start
=
on a re-boot. From James=92s instructions, this is what I have in the
rc.lo=
cal file:

=20

#!/bin/sh

#

# This script will be executed *after* all the other init scripts.

# You can put your own initialization stuff in here if you don't

# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local

/usr/local/sbin/motd.sh > /etc/motd

/usr/src/zaptel/fxotune -s

/usr/sbin/amportal start

/usr/share/axc/axc.pl &

Is this correct?

How can I tell what=92s running and if there was a problem loading it?

Thanks,

Paul.

=20

=20

________________________________

YAHOO! GROUPS LINKS=20

=20

*	 Visit your group "xap_automation <http://groups.yahoo.com/group/xap_auto=
mation> " on the web.
=09=20=20
*	 To unsubscribe from this group, send an email to:
xap_automation-unsubscribe@xxxxxxx <mailto:xap_automation-unsubsc=
ribe@xxxxxxx?subject=3DUnsubscribe>=20
=09=20=20
*	 Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
<htt=
p://docs.yahoo.com/info/terms/> .=20

=20

________________________________


------_=_NextPart_001_01C64E9B.7BB78EEF
Content-Type: text/html; charset=Windows-1252
Content-Transfer-Encoding: quoted-printable

<html><body>

<tt>






<div class=3D"Section1">

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;">I also tried adding it as a
bootup ac=
tion
in Webmin and then tried to manually start it but got the
error:<o></o></sp=
an></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;"><o>&nbsp;</o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;"><o>&nbsp;</o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"3"
color=3D"black" face=3D"Times New R=
oman"><span
style=3D"font-size:12.0pt;color:black;">Executing
</span></font=
><font size=3D"2" color=3D"black"
face=3D"Courier New"><span style=3D"font-=
size:10.0pt;font-family:&quot;Courier
New&quot;;color:black;">/etc/rc.d/ini=
t.d/axc
start</span></font><font
color=3D"black"><span style=3D"color:black;">
.. <=
o></o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"black" face=3D"Courier New=
"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier
New&quot;;color=
:black;">Can't locate
Config/IniFiles.pm in @INC (@INC contains: ./lib ./lib/site
/usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_=
perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/ven=
dor_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
/usr/share/axc/axc.pl line
37.<o></o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"black" face=3D"Courier New=
"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier
New&quot;;color=
:black;">BEGIN
failed--compilation aborted at /usr/share/axc/axc.pl line
37.<o></o></span>=
</font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;"><o>&nbsp;</o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;">I setup the action simply
as:<o></o><=
/span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
color=3D"navy" face=3D"Arial"><span=
style=3D"font-size:
10.0pt;font-family:Arial;color:navy;"><o>&nbsp;</o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
face=3D"Courier New"><span style=3D=
"font-size:10.0pt;font-family:&quot;Courier
New&quot;;">/usr/share/axc/axc.=
pl<o></o></span></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
face=3D"Courier New"><span style=3D=
"font-size:10.0pt;font-family:&quot;Courier
New&quot;;"><o>&nbsp;</o></span=
></font></p>

<p class=3D"MsoNormal"><font size=3D"2"
face=3D"Courier New"><span style=3D=
"font-size:10.0pt;font-family:&quot;Courier
New&quot;;">Is that wrong?</spa=
n></font><font size=3D"2" color=3D"navy"
face=3D"Arial"><span style=3D"font=
-size:10.0pt;font-family:Arial;color:navy;"><o></o></span></font></p>

<div>

<div>

<p><font size=3D"2" color=3D"navy"
face=3D"Arial"><span style=3D"font-size:=
10.0pt;font-family:
Arial;color:navy;">Paul.</span></font><font
color=3D"navy"><span style=3D"c=
olor:navy;">
<o></o></span></font></p>

</div>

<p><font size=3D"3" face=3D"Times New
Roman"><span style=3D"font-size:12.0p=
t;"><o>&nbsp;</o></span></font></p>

</div>

<div>

<div class=3D"MsoNormal" align=3D"center"
style=3D"text-align:center;"><fon=
t size=3D"3" face=3D"Times New Roman"><span
style=3D"font-size:12.0pt;">

<hr size=3D"2" width=3D"100%"
align=3D"center" tabindex=3D"-1">

</span></font></div>

<p class=3D"MsoNormal"><b><font
size=3D"2" face=3D"Tahoma"><span style=3D"f=
ont-size:10.0pt;font-family:Tahoma;font-weight:bold;">From:</span></font></=
b><font size=3D"2" face=3D"Tahoma"><span
style=3D"font-size:10.0pt;font-fam=
ily:Tahoma;"> <st1>xap_automation@xxxxxxx</st1>
[mailto:<st1>xap_au=
tomation@xxxxxxx</st1>] <b><span
style=3D"font-weight:bold;">On Beh=
alf Of </span></b>Paul Gale<br>
<b><span
style=3D"font-weight:bold;">Sent:</span></b> 23
March 2006 16:49<b=
r>
<b><span
style=3D"font-weight:bold;">To:</span></b>
<st1>xap_automation@yah=
oogroups.com</st1><br>
<b><span
style=3D"font-weight:bold;">Subject:</span></b>
[xap_automation]
Installing axc - need
help</span></font><o></o></p>

</div>

<p class=3D"MsoNormal"><font size=3D"3"
face=3D"Times New Roman"><span styl=
e=3D"font-size:
12.0pt;"><o>&nbsp;</o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">I installed Greg=92s Asterisk plugin a while ago but never
got it t=
o start
on a re-boot. From James=92s instructions, this is what I have in the
rc.lo=
cal
file:</span></font><font size=3D"2"
face=3D"Courier New"><span style=3D"fon=
t-size:10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span></font></=
p>

<p class=3D"MsoNormal"><tt><font
size=3D"2" face=3D"Courier New"><span styl=
e=3D"font-size:
10.0pt;"><o>&nbsp;</o></span></font></tt></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">#!/bin/sh</span></font><o></o></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">#</span></font><font size=3D"2"
face=3D"Courier New"><span style=3D=
"font-size:
10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;"># This script will be executed *after* all the other init
scripts.<=
/span></font><font size=3D"2" face=3D"Courier
New"><span style=3D"font-size=
:10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;"># You can put your own initialization stuff in here if you
don't</s=
pan></font><font size=3D"2" face=3D"Courier
New"><span style=3D"font-size:1=
0.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;"># want to do the full Sys V style init
stuff.</span></font><font si=
ze=3D"2" face=3D"Courier New"><span
style=3D"font-size:10.0pt;font-family:&=
quot;Courier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">touch
/var/lock/subsys/local</span></font><font
size=3D"2" face=3D"=
Courier New"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier New&=
quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">/usr/local/sbin/motd.sh &gt;
/etc/motd</span></font><font size=3D"2=
" face=3D"Courier New"><span
style=3D"font-size:10.0pt;font-family:&quot;Co=
urier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">/usr/src/zaptel/fxotune
-s</span></font><font size=3D"2" face=3D"Co=
urier New"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier New&qu=
ot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">/usr/sbin/amportal start</span></font><font
size=3D"2" face=3D"Cour=
ier New"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier New&quot=
;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">/usr/share/axc/axc.pl
&amp;</span></font><font size=3D"2"
face=3D"C=
ourier New"><span
style=3D"font-size:10.0pt;font-family:&quot;Courier New&q=
uot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">Is this correct?</span></font><font
size=3D"2" face=3D"Courier New"=
><span style=3D"font-size:10.0pt;font-family:&quot;Courier
New&quot;;"><o><=
/o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">How can I tell what=92s running and if there was a problem
loading =
it?</span></font><font size=3D"2"
face=3D"Courier New"><span style=3D"font-=
size:10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">Thanks,</span></font><font
size=3D"2" face=3D"Courier New"><span st=
yle=3D"font-size:10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span=
></font></p>

<p><font size=3D"2" face=3D"Arial"><span
lang=3D"EN-GB" style=3D"font-size:=
10.0pt;font-family:
Arial;">Paul.</span></font><font
size=3D"2" face=3D"Courier New"><span styl=
e=3D"font-size:10.0pt;font-family:&quot;Courier
New&quot;;"><o></o></span><=
/font></p>

<p class=3D"MsoNormal"><tt><font
size=3D"2" face=3D"Courier New"><span styl=
e=3D"font-size:
10.0pt;"><o>&nbsp;</o></span></font></tt></p>

<p class=3D"MsoNormal"><font size=3D"3"
face=3D"Times New Roman"><span styl=
e=3D"font-size:
12.0pt;"><o>&nbsp;</o></span></font></p>





</div></tt>

=20=20

<!-- **begin egp html banner** -->

<br>
<div style=3D"text-align:center; color:#909090;
width:500px;">
<hr style=3D"border-bottom:1px; width:500px;
text-align:left;">
<tt>YAHOO! GROUPS LINKS</tt>
</div>
<br>
<ul>
<tt><li type=3Dsquare>&nbsp;Visit your group "<a
href=3D"http://groups.ya=
hoo.com/group/xap_automation">xap_automation</a>" on the
web.<br>&nbsp;</tt=
>
<tt><li type=3Dsquare>&nbsp;To unsubscribe from this group,
send an email=
to:<br>&nbsp;<a href=3D"mailto:xap_automation-unsubscribe@xxxxxxx?=
subject=3DUnsubscribe">xap_automation-unsubscribe@xxxxxxx</a><br>&n=
bsp;</tt>
<tt><li type=3Dsquare>&nbsp;Your use of Yahoo! Groups is
subject to the <=
a href=3D"http://docs.yahoo.com/info/terms/";>Yahoo!
Terms of Service</a>.</=
tt>
</ul>
<br>
<div style=3D"text-align:center; color:#909090;
width:500px;">
<hr style=3D"border-bottom:1px; width:500px;
text-align:left;">
</div>
</br>

<!-- **end egp html banner** -->


</body></html>

------_=_NextPart_001_01C64E9B.7BB78EEF--




xAP_Automation Main Index | xAP_Automation Thread Index | xAP_Automation Home | Archives Home

Comments to the Webmaster are always welcomed, please use this contact form . Note that as this site is a mailing list archive, the Webmaster has no control over the contents of the messages. Comments about message content should be directed to the relevant mailing list.