The UK Home Automation Archive

Archive Home
Group Home
Search Archive


Advanced Search

[Message Prev][Message Next][Thread Prev][Thread Next][Message Index][Thread Index]

Re: TOM10 xAP Connector


  • Subject: Re: TOM10 xAP Connector
  • From: "Kevin Hawkins" <lists@xxxxxxxxxxxxxxxxx>
  • Date: Mon, 22 Nov 2004 01:36:53 -0000



--- In xAP_developer@xxxxxxx, "Stuart Poulton"
<stuart.poulton@a...> wrote:
> Hi All,
>
> Some input is required, I've now got a connector for the Tom10
temp board working...... Based around Patrick's qtemp unit and
schema.
>
> Example output below.
>
> Should inputs with no sensor present return "NotPresent" or
some
such, or just not have the entry present at all ?
>

I know weve spoken offlist but i think the relevent key/value pair
should just be omitted. However any app reading that sensor wouldn't
pick up any data and n/a might be more useful

BSC will be a great schema for this too Stuart but you will need to
set the 'hysteresis' of the temp changes before xAPBSC.event
messages are sent and also a frequency of events I guess.  Looking
forward to seeing this.. A config message would do this. In an even
more sophisticated implemenation then threshold 'alarm' levels would
be used to trigger an appropriate message.  In BSC missing sensors
would just not have a corresponding sub address present.

Kevin







xAP_Development Main Index | xAP_Development Thread Index | xAP_Development Home | Archives Home

Comments to the Webmaster are always welcomed, please use this contact form . Note that as this site is a mailing list archive, the Webmaster has no control over the contents of the messages. Comments about message content should be directed to the relevant mailing list.